Mercedes-Benz GLA Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter #1
I have my last service scheduled while my car is still under the Mercedes Benz Used Car Warranty next month. The car has been without flaws. I had one warranty service a couple of years ago to change the PCV valve ($1200 service that was free).

Is there anything I should have the dealership check closely and fix under warranty?
 

·
Registered
Joined
·
46 Posts
Pull up your engine cover and check and see if the cover is rubbing on the silver hoses running underneath. Some 2015’s had a clearance issue with this.
 

·
Moderator
Joined
·
622 Posts
I hope your dealer is like mine and when doing a scheduled service they do a complete check. In fact, they sent me a video of things they found that might need attention in the future. It was the underside showing checking the tire wear and brake pads wear with comments. Mine also does a free alignment check.

With that said if there is anything as the driver thinks is not working right call it to their attention.
 

·
Super Moderator
Joined
·
1,661 Posts
There was a recall for the clock spring inside the steering wheel. Also possible software updates for maps, shifting, throttle, etc.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #5
There was a recall for the clock spring inside the steering wheel. Also possible software updates for maps, shifting, throttle, etc.
The Clock Spring was fixed before I purchased the car.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #6
I hope your dealer is like mine and when doing a scheduled service they do a complete check. In fact, they sent me a video of things they found that might need attention in the future. It was the underside showing checking the tire wear and brake pads wear with comments. Mine also does a free alignment check.

With that said if there is anything as the driver thinks is not working right call it to their attention.
So thing that are not working right now are the Auto Start Stop. I was thinking it might be because I am over the 1 year service internal but I do not know. Also the parking brake doesn't always release automatically (happened once).
 

·
Moderator
Joined
·
622 Posts
So the thing that are not working right now is the Auto Start-Stop. I was thinking it might be because I am over the 1-year service internal but I do not know. Also, the parking brake doesn't always release automatically (happened once).
The Auto Start/Stop most likely is the battery for that feature. It is separate from the regular car battery. It is located in the footwell on the passenger side under the floor mat with the fuses. There have been firmware updates for the start/stop over the years. I had a 2016 and they replaced the battery and did firmware updates and it worked after that with no problems.

Parking brake one time might have been an error on your part. I had this to happen when I did not do a thing in a normal matter in the opening door, start or stopping the engine, and change the gear selection. Did something and the brake stated on.
 
  • Like
Reactions: rvittori
1 - 7 of 7 Posts
Top