Mercedes-Benz GLA Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
4 Posts
You don't mention which GLA model and year, nor location (Pep Boys sounds like US), but you report symptoms of a sticking thermostat. However, our GLAs, and MBs in general, also have a tendency at times for bogus sensor readings for a number of various reasons. Is your GLA still under warranty? Perhaps the best option for hopeful peace of mind is taking it to an MB dealer to determine if any error codes are in the recent record, and also to ensure MB-approved parts are used if necessary.
Gla250 2016 I took it to the dealer and they said they found nothing. As I was still under 50k miles it started doing it again now it is doing it daily. I am unhappy because I brought it in and have video of what it does. I am about to take it back tomorrow and I am hoping they have it all documented. I really like this car but I am worried all the time now that something will go wrong
 

·
Registered
Joined
·
9 Posts
Hello. So this is strange. Drove around for 20mins and the engine temperature went past "H" in the red but there were no notifications/alerts telling me to shut off engine yesterday. Then today, kept it in my garage and revved engine to 3.5 rpms for 20mins and the temp hit "H," no alert/notification to shut engine off. There are no awkward noises, fan is kicking in, and coolant level remains filled. (Trying to upload video for when it hit "H" but the forum is saying its to large
 

Attachments

·
Registered
Joined
·
1 Posts
2015 GLA here located in NJ. I just had a water pump failure at 53k. Unfortunately out of warranty, $2700 to replace........ has anyone purchased an extended warranty after the fact? Really wishing I had purchased it at the time I bought the car as a CPO.
 
21 - 24 of 24 Posts
Top