Mercedes-Benz GLA Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello,
I've Owned my GLA45 for a year now, it has 47K (29K miles I think) and my car won't get into gear (when it goes from 2nd to 3rd) over 3,000 rpm the rpm goes crazy and the car keeps delaying on going into gear. When I fill the car with gas it keeps stopping suddenly, some people tell me it has a problem with the fuel injectors. I really don't want to end up changing the transmission. Can anyone help me with this issue.
Thank you
 

·
Super Moderator
Joined
·
2,192 Posts
Sensors are a pox on modern cars. Voltage is a pox on sensors. Always check the battery first.

Voltage spikes are also bad. Spark plugs and coil packs can create havoc.

A good place to pull information from is the OBD II port. Readers are cheap and it's always good to look for error codes.
 

·
Premium Member
Joined
·
1,096 Posts
Yes, see if you can get the codes of what is causing problems. Start with an OBD II reader as Wayne suggested and if no codes you might need to go to a shop that has a reader that reads more than the simple readers do.
 
  • Like
Reactions: Huey52

·
Registered
Joined
·
1 Posts
Hi All.
just bought my first Gla 2015 lovely car but I’m having the same problem I start the car and the transmission malfunction light comes on with the EML. Tried the reset as I read on here didn’t work took it back to the garage where I bought it from they bought a brand new battery for it all was good driving home no issues. Just came to start it up and the Transmission Malfunction sign has reappeared but with no EML light this time. Has anyone experienced this andhow did they resolve it. Any help would be greatly appreciated
 
1 - 4 of 4 Posts
Top