Mercedes-Benz GLA Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Helllo,

I have a 2016 GLA 250.

Yesterday, my iPhone cable connected to the right port (#2) came in contact with the metal ring on my cigarette lighter. I saw a small spark and now the port will not charge nor support Carplay.

The left port (#1) works and will charge my Android and Apple phones. Nothing for the right port (#2).

Is it the fuse, or the USB module, or something worse? Thanks in advance.


26925
 

·
Super Moderator
Joined
·
690 Posts
If one USB port still works it's unlikely a fuse, as they're likely on the same circuit. So I suspect that one port's circuitry is now dead. I'm not sure if they may be separately replaced or one module for both.

Related, this past Winter I inadvertently rug static shorted an Xbox controller when plugging in the charge cable by also touching at exactly the wrong spot (always a difficult socket to align). I saw the spark as well and that was that. Had to quickly order a new one so my granddaughter could play her farming game. :oops: The upside is that the new controller is USB-C so a much easier connection and therefore unlikely to again happen.
 

·
Registered
Joined
·
162 Posts
OP, I think your best option is to try and replace the USB connection hub. Looks like you’ll need two parts.

1. The USB hub itself, which is part #: 172820200080. This replaces part #: 1728201600 if you see it in cross reference

Here’s a link: 2016 Mercedes-Benz Connector 172-820-20-00-80 | MB OEM Parts

2. You’ll need some sort of trim puller. I’d just buy the OEM one, part #: 000589886300

Here’s a link: Radio / Climate Control Panel Removal Tools

When you actually go to do the swap, it should be straight forward. There are two small slots that you have to push the ‘key’/tool into to release a clip, then the whole thing slides out like a cassette. There’s a blue connector on the bottom that you have to release, then install everything backwards.

If this doesn’t work, then it might be something fried more downstream, and probably a dealer trip.. but since you have one port working and the parts looks to be only around $50, I think I’d give it a shot. Good luck!
 

·
Registered
Joined
·
162 Posts
Little bump here. You got me somewhat worried about doing this myself, so went ahead and ordered these.. might be worth looking into too..

 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
OP, I think your best option is to try and replace the USB connection hub. Looks like you’ll need two parts.

1. The USB hub itself, which is part #: 172820200080. This replaces part #: 1728201600 if you see it in cross reference

Here’s a link: 2016 Mercedes-Benz Connector 172-820-20-00-80 | MB OEM Parts

2. You’ll need some sort of trim puller. I’d just buy the OEM one, part #: 000589886300

Here’s a link: Radio / Climate Control Panel Removal Tools

When you actually go to do the swap, it should be straight forward. There are two small slots that you have to push the ‘key’/tool into to release a clip, then the whole thing slides out like a cassette. There’s a blue connector on the bottom that you have to release, then install everything backwards.

If this doesn’t work, then it might be something fried more downstream, and probably a dealer trip.. but since you have one port working and the parts looks to be only around $50, I think I’d give it a shot. Good luck!
You were right! The port was dead. Replace the connector and back in business!

I ordered the connector and tools from Amazon. I paid a bit more for the connector but I wanted Amazon's speed and good return policy.

Problem solved! Many thanks!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
Little bump here. You got me somewhat worried about doing this myself, so went ahead and ordered these.. might be worth looking into too..

I went in a different direction and removed the lighter altogether. I posted the how-to here. Simple mod for about $45 for parts and tools.
 
1 - 6 of 6 Posts
Top