Mercedes-Benz GLA Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi Folks,

Just wondering if anyone's GLA has ever shifted from Drive to Neutral while stopped at a red light and NOT automatically returned to Drive when releasing the brake and attempting to accelerate. It has happened several times to my 2015 GLA 250 and I have had to manually shift back to Drive. Scary and hoping it's not a major transmission issue.

Thanks in advance and sorry if this question has already been asked.
 

·
Super Moderator
Joined
·
1,947 Posts
Never. Nor have I heard reports of this. The dash display indicates neutral? I suspect a shifter switch adjustment problem but I'm not sure if there is a speed lockout to ignore the shift switches when not stopped (the 45 shifter is completely different).
 

·
Registered
Joined
·
2 Posts
Yes! My certified 2018 just started doing this and also shifts to neutral while driving! It’s very scary. I am at the dealership now awaiting a diagnostic. I just bought this car a few days ago
 

·
Registered
Joined
·
2 Posts
I’m having the same issue, and just bought the car a few months ago..

it’s happened while driving and while at a stop light..

interested in what the dealer says.. I’m def gonna need to take mine in, it’s a horrible feeling especially with such an expensive car.
 

·
Registered
Joined
·
15 Posts
This happened to me yesterday after driving perhaps 1 mile as soon as I got on the highway and it was the scariest thing ever.

I just got this car, but I didn't buy it new. We thought we were going to die.

Please let me know if you've found something because I can't fathom how a car that does this hasn't been recalled.
 

·
Registered
Joined
·
2 Posts
I bought a brand new GLA250 in 2016. For the past 5 years it was good. Yesterday it happened twice and today it happened once, exactly like all of you guys experienced---- the car was switched to neutral at red light and/or stop sign. It won't switch back, I had to turn off the car and then started again to drive. I called the dealership and they just set up an appointment with me told me bring in to check. I will post again if I have any results from the service.
 

·
Registered
Joined
·
15 Posts
I bought a brand new GLA250 in 2016. For the past 5 years it was good. Yesterday it happened twice and today it happened once, exactly like all of you guys experienced---- the car was switched to neutral at red light and/or stop sign. It won't switch back, I had to turn off the car and then started again to drive. I called the dealership and they just set up an appointment with me told me bring in to check. I will post again if I have any results from the service.
I called Mercedes and they picked up the car in 30 minutes. They said I should know by tomorrow.
 

·
Super Moderator
Joined
·
1,947 Posts
Take your phone and show them this thread so they will know you're not alone with this problem. Let us know what you find.
 

·
Registered
Joined
·
15 Posts
just an update.

I received a call from Mercedes mechanic today that was appalling. He sent me some texts about replacing my front tires. Then called me to constantly repeat my car is out of warranty and that there's no recall on the car (even though there is a recall on the exact same issue for the last rendition of this model 2019).

I said: "something has to be done because its an apparent issue that many of us are experiencing, and this is the scariest thing i ever experienced in my life, I almost died!"

He said: "you almost died because of that bad tire on the front".

I lost it at that point. Couldn't believe after all the proof I showed him he was trying to find a random reason to make this a fault of mine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #14 · (Edited)
Hi Folks,

Just an update since my original post.

For the past 10 months, I have been deactivating the Eco-mode when I start driving so my GLA250 no longer shifted to neutral at red lights. Then recently, the check engine light came on and I was told that my main and auxiliary batteries needed replacement. After replacing both batteries by myself (dealer wanted $900+), the problem seemed to have fixed itself. I'm not sure if this will work with others', but just wanted to share my experience.

*** Tip: Make sure to plug in an auxiliary battery backup before changing the main battery under the hood (in case auxiliary battery is dead as well).

Good luck!
 
1 - 14 of 14 Posts
Top