Mercedes-Benz GLA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all, first time posting on this forum. I'm a 2018 GLA45 owner.

I noticed a loud clicking/ticking noise after turning off the car after about 15 min of driving. Prior to turning off the car, I did notice all the temperature gages seemed normal. The noise last for about 2-3min then it stopped. An immediate engine restart and shutoff resulted in the same clicking/ticking noise. I tried again (restart/shutoff) several hours later so the engine is cold and did not hear the clicking/ticking noise.

Couldn't find anything on this forum, but came across a thread ("Weird clicking noise once I shut the engine off") on the xbimmers forum describing a similar issue and identifying the source to a broken water coolant pump for the turbo.

Has anybody encounter this issue for GLA? I have a link to a video, but cannot post due to first-time poster.
 

·
Super Moderator
Joined
·
1,406 Posts
Welcome to the GLAowners forum. This has come up before and consensus was it was cat converters under the chassis cooling down. A similar question came up on a soft motor noise from the engine compartment long after shutdown, which pointed to a pump circulating fluid to cool the turbo, IIRC. Both are normal for our GLAs.

We’re an international group with a variety of GLA derivatives. As a reference to others in future posts, it helps to add location, GLA model and year to your member profile, which then displays under your name. You can do that from the User CP link on the upper right of most browsers.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
@turbolink, thanks for the comment! Could I DM you a link to the video to confirm it is indeed cat converters cooling down. This is my first time hearing it from my car after ~1.5yrs of daily driving.
 

·
Super Moderator
Joined
·
1,406 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #5
[Update]: Took it to the dealer. Confirmed that transmission cooler pump was failing and needed replacement. Once replaced, the ticking noise stopped.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Covered under warranty. I don't know if it is a common issue for GLA45, but there is a thread on "water pump failure" on this forum mostly identified by overheating warning lights if I recall.

I was able to find another video showing a similar clicking noise after engine shutoff and ended up being a failing coolant pump on the xbimmers forum; thread title is "Weird clicking noise once I shut the engine off". I'm still new to this forum and cannot post links.
 
1 - 9 of 9 Posts
Top