Mercedes-Benz GLA Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello!

I recently got my first benz, and I wanted to have it hardwired and setup! I'm installing it to the passenger foot well but I can't find an image or diagram to let me know which fuse port I am able to safely use. would anyone know which would be best for Batt and ACC/ignition please?

Thanks,
Kevin

Circuit component Electronic engineering Audio equipment Hardware programmer Electrical wiring
 

·
Registered
2020 MB GLA250 4MATIC Avantgarde Edition
Joined
·
147 Posts
Hello!

I recently got my first benz, and I wanted to have it hardwired and setup! I'm installing it to the passenger foot well but I can't find an image or diagram to let me know which fuse port I am able to safely use. would anyone know which would be best for Batt and ACC/ignition please?

Thanks,
Kevin

View attachment 27778
The bolt on the right side of the orange 40 amp fuse is a battery connection. why would you run a ground wire there? remove it immediately, you're going to make a very expensive problem for yourself if you try and ground it there. there should be a fuse box in the boot of the car that contains the fuse diagram, otherwise, get one from the dealership or search on google.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The bolt on the right side of the orange 40 amp fuse is a battery connection. why would you run a ground wire there? remove it immediately, you're going to make a very expensive problem for yourself if you try and ground it there. there should be a fuse box in the boot of the car that contains the fuse diagram, otherwise, get one from the dealership or search on google.
thanks!

ya, I ended up moving the ground to another area after realizing this. I thought connecting it to any metal that was touching the chassis would be ok but maybe i couldn't see closely enough. I'm not sure if the car was too new but I couldn't easily find a diagram on a search or on the manual. after finding a proper ground, it didn't take much time finding the right port.
 

·
Registered
2020 MB GLA250 4MATIC Avantgarde Edition
Joined
·
147 Posts
thanks!

ya, I ended up moving the ground to another area after realizing this. I thought connecting it to any metal that was touching the chassis would be ok but maybe i couldn't see closely enough. I'm not sure if the car was too new but I couldn't easily find a diagram on a search or on the manual. after finding a proper ground, it didn't take much time finding the right port.
No problem! glad you noticed that before it became an issue. it would be sad to see any major electrical issues on a new AMG. dealer wouldn't warranty that either.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Hey @omgamgman, any chance you can share which fuses you ended up using? I can't get my parking mode to work correctly for some reason.
Hey. I was a dummy and didn't take an after picture of my fuse box after setting it up. Can't say for sure... my problem was mostly the ground though to get a proper connection more-so an issue with which fuse I used. Just to confirm, where are you connecting the ground? Do you have some pictures of yours?
 

·
Registered
2022 GLA250 4MATIC
Joined
·
15 Posts
I took a picture of the fuse connections but not of my connection to ground. I connected off too the bottom right of the fuses somewhere into the chassis. I mean, I've had the camera working for months already and it records while driving, but never bothered to fix the parking mode until now
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
I took a picture of the fuse connections but not of my connection to ground. I connected off too the bottom right of the fuses somewhere into the chassis. I mean, I've had the camera working for months already and it records while driving, but never bothered to fix the parking mode until now
Ah gotcha, then it just seems like you have to find another slot where it supports the detection of AC as well. Sorry, not sure which one without opening it back up.
 

·
Registered
2022 GLA250 4MATIC
Joined
·
15 Posts
Ah gotcha, then it just seems like you have to find another slot where it supports the detection of AC as well. Sorry, not sure which one without opening it back up.
no problem, all good, thanks! just wanted to see if you managed to find a fusebox diagram somewhere. I'm having a ton of trouble with that, and there's no documentation nearby either (maybe it's under the hood?). I just got anxiety about tinkering with a car is all as I'm not much of a car guy!
 
1 - 9 of 9 Posts
Top