Mercedes-Benz GLA Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a GLA 220D 4Matic 170hp I think that is an X156.905 more precisely

After 3 years of driving I got a DPF soot content high error code P2463 and P2463(09)

Forced regen didn't help so the filter was removed from the car and sent to a company that cleaned it.
This company measured the pressure loss across the DPF before and after cleaning and claimed it was as good as new.

PROBLEM: The error codes stays! -I clear the codes and they come back after 20/30 minute driving
Do I need to tell the ECU that the filter is replaced? If so how do I do it?

The diagnose tool can display the exhaust pressure and its at idle close to atmospheric pressure
Reving and especially accelerating the car, increases exhaust pressure to around 3bar (0.2 psi)
Is that normal pressure?
If its high, and thefilter is clean, -can it be the differential pressure sensor?
...or is that unlikley since it does display a varied pressure and is not stuck 0 or high.

Also: Once in a while, I do get a P061(00) error code
I THINK that is because with the engine light on, if I rev high, the engine doesn't deliver the expected torque so I THINK this is just a consequence of hte DPF issues -maybe I'm wrong...

Does anyone have any ideas on how to proceed. -Handing the car over to Mercedes is bound to be 4000£+ so since the DPF is pressure tested OK, I'd like to try to sort this my self

I could really use your valuable input here

Kind regards

Per Viklund
 
1 - 1 of 1 Posts
Top