Mercedes-Benz GLA Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
It seems like the only person who can help me now is Jesus. I have been having this issue ever since I went stage 1 tune from eurocharged. If I do race start on my 2017 GLA 45, I would always get this message "4matic currently unavailable" at the end of first gear when it's about to shift to second. I have tried EVERYTHING. Since everyone talks about wheel spin being the main culprit, I got wide tires, lowered the psi to 22, warmed up the tires, nice hot day, and prepped the track with sticky substance. It hooked incredibly but again, at the end of 1st gear when it's about to shift to second, it cuts off power completely and says "4matic currently unavailable". At this point I have 2 options, either I let off and or stay in it and after 3 seconds it goes back to being a rocket. I currently have stage 2 tune and TCU tune with eurocharged. The shifts on race start are INSTANT.. when I stay in it after the message. I don't know what's causing this issue. My buddy has a 2018 CLA 45, same exact tires, same tune ECU and TCU, same road, same time launching it, same spinning, but his doesn't cut off, mine does. I can only brake boost if I want to "drag race", that will not cut power, but it does not kick as hard or shift instant like race start does.

What is causing this issue??????????
Is it a bad battery? (It has been previously replaced with another OEM, weird for a 2017 car)
Is it bad wheel sensor?
Is it second gear clutch slipping?
Is it a bad rear differential?
Is it software or hardware??

I have no fkin clue. I'm sick and tired of this BS. The launch control is where this car should shine and I can't even do it.
 

·
Super Moderator
Joined
·
2,144 Posts
That does suck. If I were you I would be taking steps backward on my mods until, if necessary, your back to stock. If it still won't launch with no mods then you have a case with MB.

My process is so what's cheapest and easiest first. I'd get rid of the tune to start.
 

·
Premium Member
Joined
·
351 Posts
It seems like the only person who can help me now is Jesus. I have been having this issue ever since I went stage 1 tune from eurocharged. If I do race start on my 2017 GLA 45, I would always get this message "4matic currently unavailable" at the end of first gear when it's about to shift to second. I have tried EVERYTHING. Since everyone talks about wheel spin being the main culprit, I got wide tires, lowered the psi to 22, warmed up the tires, nice hot day, and prepped the track with sticky substance. It hooked incredibly but again, at the end of 1st gear when it's about to shift to second, it cuts off power completely and says "4matic currently unavailable". At this point I have 2 options, either I let off and or stay in it and after 3 seconds it goes back to being a rocket. I currently have stage 2 tune and TCU tune with eurocharged. The shifts on race start are INSTANT.. when I stay in it after the message. I don't know what's causing this issue. My buddy has a 2018 CLA 45, same exact tires, same tune ECU and TCU, same road, same time launching it, same spinning, but his doesn't cut off, mine does. I can only brake boost if I want to "drag race", that will not cut power, but it does not kick as hard or shift instant like race start does.

What is causing this issue??????????
Is it a bad battery? (It has been previously replaced with another OEM, weird for a 2017 car)
Is it bad wheel sensor?
Is it second gear clutch slipping?
Is it a bad rear differential?
Is it software or hardware??

I have no fkin clue. I'm sick and tired of this BS. The launch control is where this car should shine and I can't even do it.
Hey, first thing that pops to mind is the wheel speed sensors reporting numbers that didnt add up.

Take steps to ensure the functional tire diameter is equal all around, and within the alarm point delta what the ECU has stored as reference
 
1 - 7 of 7 Posts
Top