Mercedes-Benz GLA Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
I don't actually use the gps a lot, but I've noticed that when I do, the unit seems to be resetting every time I hit a tar strip or bump. The reset is quick, usually a matter of 30 seconds... but it is annoying. I've got navigation in our Cayenne, which is our "traveling" car, and it's rock steady over the same roads.

Just curious as to whether this is an issue others have experienced, whether it's a loose connection that I can check, or it's a dealer issue? My car was a CPO, no manual with the Garmin GPS, so I figure I'd ask here before going to the dealer.
 

·
Registered
Joined
·
535 Posts
I see you have a 2015 GLA does the navi use a SD card or another device for nav? Either way sounds like something is lose. It is a CPO I would go back to the dealer.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
I see you have a 2015 GLA does the navi use a SD card or another device for nav? Either way sounds like something is lose. It is a CPO I would go back to the dealer.
It's a Garmin system, and I don't have a manual for it, so I'm not sure if it uses a SD card or whatever. I think it's a vehicle at was "pre-wired" and the previous owner either put it in or had the dealer install it. I'm gonna google it see if I can figure this out, it's either a lose card (?) or faulty wiring. The gps works fine until I hit a bump in the road, then it goes blank and a message comes up on the screen saying it's activating the gps and a countdown timer appears and 10 seconds later the map reappears. But if your close to a route change and hit a bump, you can easily miss the exit. Like I said, don't use it much, hate to go thru the hassle of dropping it off for a day if it's something I can troubleshoot and fix. Was really hoping it was a problem that a few others might've dealt with so I'd get some tips, but it'll get fixed one way or the other.
 

·
Registered
Joined
·
535 Posts

·
Registered
Joined
·
8 Posts
I had/have the same issue on my 2015 – nav cuts out over bumps. Becker Nav didn’t come with the car, so I added it later. Worked fine the first couple months, even the display cut out a few times, but mostly in nav mode. Took it in for B service and diagnostics showed several odd “faults”. Updated the car software, still same problem. They determined it was a bad harness and they replaced under warranty. Worked fine for a few months and it’s back again. I’ll repost after I take it in again if I get any new info.

Like you, I don’t use the nav much, but it is annoying. For what I spent on the module, and the poor interface it has with my home computer and other devices, I may just take it out and sell it and go back to a dedicated GPS unit or my phone. Both are far cheaper.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #6
Check inside the glove box and see if there is a small box attached to the car inside the glove box. The 2015 GLA used either Command or Becker Map Pilot. Sounds like you have the Becker Map Pilot. Check this website for some into on the Becker map pilot

You are being redirected...

or

https://gpsnavigationsite.com/the-becker-map-pilot-for-mercedes-cars/amp/

Manual
https://www.beckermappilot.com/manuals/Manual_MAP_PILOT_EN.pdf

Yup... you were right, it's a Becker Map Pilot. So yeah, just for kicks I went into the glove box, and eventually ejected the main cartridge. What I did after looking everything over was did a few inserts and ejections, then went for a ride. Amazingly, it stays on driving around so far. When I got back to the house, I gave the dash above the glove box a good hard slap... and it recycled. Tried it on the road again... still worked, but slap the dash and it recycles. So it looks like maybe the cartridge wasn't well seated, but now it's seated better. But something in the area of the gps module is loose, and I guess I should make an appointment to have it checked. It's under warranty.
 

·
Registered
Joined
·
535 Posts
Cars without Command Mercedes for a few years most of there cars came pre-wired for Navi. The earlier models had Becker Map Pilot and you just bought the module and just plugged it in. It was able to be moved from car to car. In 2016 the GLA changed to Garmin Map Pilot that uses a SD card. The SD card is coded to be used in one car only and can not be moved between cars.
 
1 - 7 of 7 Posts
Top