Mercedes-Benz GLA Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Greetings,
I was Soooo excited when I finally purchased my first Mercedes Benz this year!
I bought the GLA because I felt that MB were very safe and the car looks great.
Immediately and continuously I have had transmission problems bringing the vehicle back to the dealer several times.
Often when I initially go forward or reverse the vehicle violently lunges with a loud bang scaring the **** out of me every time.
I have had others in the vehicle with me when this happens and every time the reaction is "what was that!" thinking I was rear ended or hit something.
The dealer tells me that it is a "wet" transmission and is meant to be driven and that I should not be so conservative in my acceleration??? If I rapidly accelerate then the lunge is just more violent.
The dealer has also mentioned that I am not the only one to have this complaint.
I just don't know what to do because I would have never purchased this vehicle if I knew that it would be so scary to drive.
 

·
Registered
Joined
·
48 Posts
Mercedes GLA Forum > 2014+ Mercedes GLA Tech Section > Engine and Technical Discussion > Transmission woes

Read this post and you should have your answer...seems quite a few have had this issue and was fixed by the dealer...maybe you need to show your dealer the post...
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top