Mercedes-Benz GLA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi All,

First post from Australia, recently had my B service done to my 2016 AMG GLA45 (39600km) all went well except when the technician said there was a code stating a fault to the oil pump valve sensor, he said to fix this issue the sump must be removed to replace the part.

Pre and post B service there wasn't any dash lights or error messages on the console (technician said the code showed up on his plug in) so I am a little bit unsure what to do...

Thanks in advance, any input would be great.

Cheers
Eric
 

·
Registered
Joined
·
121 Posts
This surely is a “revoltin’ development." What is the warranty period for your car? Friend in Perth says his has a 5 year period.

The car cannot be far out of warranty (time) and has low kms (<40K kms). Has it been serviced to MB standards, hopefully at a dealer, since new? As this cannot be a cheap repair and something that should not fail (and also not display) so would be asking dealer to go back to MBA for a policy assisted repair. In Canada, this is the best way to handle and MBC is normally good to support clients (particularly AMG's) with issues like this.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
This surely is a “revoltin’ development." What is the warranty period for your car? Friend in Perth says his has a 5 year period.

The car cannot be far out of warranty (time) and has low kms (<40K kms). Has it been serviced to MB standards, hopefully at a dealer, since new? As this cannot be a cheap repair and something that should not fail (and also not display) so would be asking dealer to go back to MBA for a policy assisted repair. In Canada, this is the best way to handle and MBC is normally good to support clients (particularly AMG's) with issues like this.
Thanks for your response YYZGLAguy, however my warranty has lapsed, but I think the code was P06DA00.


Cheers
Eric
 

·
Registered
Joined
·
121 Posts
Thanks for your response YYZGLAguy, however my warranty has lapsed, but I think the code was P06DA00.


Cheers
Eric
If the car has been maintained at a dealer, their Service Manager should be able to get you some sort of "policy assistance." If not and if is out of warranty, you may be SOL. One of the benefits of dealer service and maintenance plans.
BTW, how much did they tell you it would cost to remedy this problem?
 

·
Registered
Joined
·
21 Posts
I had the same problem when I went to get my catless tune file installed. I originally had a check engine light come on after installing a downpipe. When I went to get it re-tuned, they saw the code, did some tests. They couldn't find any faults and nothing came back on after the tune. They told me IF the check engine light came back on, or if the oil light came on, to stop my car immediately and tow the car back.

Been driving it for almost 2 months afterwards with no issues whatsoever.

20210301_112635.jpg
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
If the car has been maintained at a dealer, their Service Manager should be able to get you some sort of "policy assistance." If not and if is out of warranty, you may be SOL. One of the benefits of dealer service and maintenance plans.
BTW, how much did they tell you it would cost to remedy this problem?
The car has been maintained at the dealer for the 3 years when it still had the warranty, however after the warranty period lapsed then the car has been maintained a MB authorsied service centre.

I have been quoted $1500.00 to remove sump, replace part then reinstate sump.

Thanks
Eric
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
I had the same problem when I went to get my catless tune file installed. I originally had a check engine light come on after installing a downpipe. When I went to get it re-tuned, they saw the code, did some tests. They couldn't find any faults and nothing came back on after the tune. They told me IF the check engine light came back on, or if the oil light came on, to stop my car immediately and tow the car back.

Been driving it for almost 2 months afterwards with no issues whatsoever.

View attachment 26685
Thanks for your input H.H. at the moment there has been no codes up on the dash or any check lights, however, I have also been told that the battery is on its way out so I guess I will change the battery and then plug in the OBD2 scanner and see if this message comes up as I read in a different forum, that the person with the same code changed the battery and the code was gone.


So fingers crossed,

Cheers
Eric.
 
1 - 9 of 9 Posts
Top