Mercedes-Benz GLA Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
36 Posts
Check engine light came on today, in normal traffic, 50mph. Car is about 9mths old, 14,900mi. Removed and retightened gas cap, turned car off and on. Driving just fine, but want it to go away. Calling dealer tomorrow. If anyone has any thoughts, or similar issues, chime in.
 

·
Registered
Joined
·
816 Posts
Do you have access to a CAN OBDII reader? A DTC would appear on the reader and you would know exactly what the fault is… you have cleared the most common issue (gas cap) and since that is not the issue the next most common fault for a check engine light is emissions issue such as a faulty O2 sensor in the exhaust stream.

I think larger auto supply shops (such as AutoZone, PEP Boys etc) have loaner readers you can use on site at their stores.
 
  • Like
Reactions: AMGz

·
Registered
Joined
·
694 Posts
Do you have access to a CAN OBDII reader? A DTC would appear on the reader and you would know exactly what the fault is… you have cleared the most common issue (gas cap) and since that is not the issue the next most common fault for a check engine light is emissions issue such as a faulty O2 sensor in the exhaust stream.

I think larger auto supply shops (such as AutoZone, PEP Boys etc) have loaner readers you can use on site at their stores.
Those same shops might have rentals although some push the urgency and make you buy one.

Rentals should be out there.
 

·
Registered
Joined
·
79 Posts
I also have over 14,000 miles and a check engine light. But mine came on after flooring it in the pouring rain on the highway. The care went into limp mode and I had to pull over and turn it off. Then it ran fine but has the check engine light. I checked all the fluids and the gas cap. Appointment with the dealer is Thursday. I might go by my local parts store first to see what there reading says prior to the dealer. I think the transmission got software got confused. But maybe it is an ECU.
 

·
Registered
Joined
·
1 Posts
I also have over 14,000 miles and a check engine light. But mine came on after flooring it in the pouring rain on the highway. The care went into limp mode and I had to pull over and turn it off. Then it ran fine but has the check engine light. I checked all the fluids and the gas cap. Appointment with the dealer is Thursday. I might go by my local parts store first to see what there reading says prior to the dealer. I think the transmission got software got confused. But maybe it is an ECU.
Ever find out why you got the check engine light in the rain? I got the same issue.
 
1 - 8 of 8 Posts
Top