Mercedes-Benz GLA Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I've bought it week ago, came fresh from the factory, and it died after 850kms of driving without any warnings, the e-start is roling but sounds like the engine isnt responding (quite similar when the timing belt is broken) . The service didnt found the issue yet. I'l keep You updated.

SOOO DISSAPOINTED!
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
I didnt want the loaner yet, still hoping they fix it soon, but if not I'l request some for sure,
from first diagnosis - the main engine computer is broken - but they arent 100% sure, at leats they are almost sure that it's not a mechanical failure, but the dashboard isnt showing up any service errors (the one available in the HUD) and all system works (lights,sunroof,blinkers, etc)
anyways, if this turn into somethign big, i'l be requesting a new car probably.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
today, i got the info that they need to take off the engine header because there is no compression at all (timing belt broken?),
still undecided should I request new car or get my money back and get something else, I definetley dont want to get this car back, even when they fix it.
what a bummer! cant belive it!
 

·
Registered
Joined
·
10 Posts
They won't give you a new car if they say they can fix it ! I tried ! The dealer had mine for 25 days . It is fixed and running fine now but it does make you not want the car back . That being said mine is running perfect! Fingers crossed!
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
They won't give you a new car if they say they can fix it ! I tried ! The dealer had mine for 25 days . It is fixed and running fine now but it does make you not want the car back . That being said mine is running perfect! Fingers crossed!
ugh **** , not good,
but all depends on how big was the issue, im getting lawyer to write the request, but first i need the service report to see what really happens.
 

·
Registered
Joined
·
694 Posts
They won't give you a new car if they say they can fix it ! I tried ! The dealer had mine for 25 days . It is fixed and running fine now but it does make you not want the car back . That being said mine is running perfect! Fingers crossed!
I know what you mean, its a wait that begs you to question the local lemon laws, either way it helps to know them just so you know when you've reached the threshold to then use it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
update:
one camshaft broken :mad::mad::mad:, two valves bendt, one piston with valve marks,

service is requesting the whole engine exchange,
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #13 ·
They are waiting what the MB Central at Stuttgard gonna say, if they recommend to fix it (new header/valves/piston) the service will fix it but i dont want it after that,
but
if they exchange the whole engine , I'll take it back ,but I'll be requesting to lower the price of the car - because they sold me invalid one, and after the repair it lost the value.
I think they gonna exchange the engine and the factory wil inspect it to find what caused that.
They gave me GLA200 as the loaner for the whole repair time,
 

·
Registered
Joined
·
694 Posts
It is getting depressing to read some of these owner posts while awaiting my 2016 order to firm up and get built. Hopefully this is an isolated case.
I think with the possibility of technical service bulletins making it into the public eye we should be able to gauge how much better those 2016s are. Hopefully there will be improvements.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #16 ·
update:
The Central decided to exchange the engine as I thought, good thing is they have it on stock, so the car should be ready next week, if anything goes wrong or i get another issue , they gonna exchange the car.
 
  • Like
Reactions: rayman

·
Registered
Joined
·
182 Posts
It is getting depressing to read some of these owner posts while awaiting my 2016 order to firm up and get built. Hopefully this is an isolated case.
If you look at the forum for any product you'll see all the "mine broke!" posts that might give you the impression that it's common. The reality is that people who bought one that works just fine have no reason to post. How many tens of thousands of these GLAs are out there? How many have issues? How many of any car have issues? I don't think the GLA is having any more issues than any other car at this point.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #20 ·
If you look at the forum for any product you'll see all the "mine broke!" posts that might give you the impression that it's common. The reality is that people who bought one that works just fine have no reason to post. How many tens of thousands of these GLAs are out there? How many have issues? How many of any car have issues? I don't think the GLA is having any more issues than any other car at this point.
Yep, that's how it is,
Mine case was one in a million probably, the camshaft came invalid from the producer,no MB fault, overall the car is awesome!
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top