Mercedes-Benz GLA Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·

·
Super Moderator
Joined
·
786 Posts
I once in a sports car swapped to a Li-ion 12V battery to save weight/space and facilitate mounting horizontally and it worked very well in those regards. Pricey indeed. Note that a lead-acid AGM battery may also be mounted in atypical orientations but of course still quite heavy.

Li-Fe is as you link is more expensive than lead-acid but not that bad. It's a step up in goodness. But then so is a lead-acid AGM and further a "deep cycle" variant.

The Aux battery is Li-ion so there's already a mix of types in the overall 12V system.

btw: In most Audi models a new battery must be "coded" into the computer system. Not sure if same for the GLA.
 

·
Super Moderator
Joined
·
2,025 Posts
I swapped out my August 2016 battery a month or so ago after enough Covid induced sitting times ran the battery flat too many times. It's important to remember to connect the battery tender!!!

The top cover slides forward, up, and off. It's a tight space to pull the OEM battery out of but the built in handles help. I installed the new non MB battery with no ill side affects and without a trip to the dealer.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 ·
So, after putting in a regular lead acid battery, I cleared a bunch of codes due to low battery voltage from the original battery fail. I keep getting these 2 codes after clearing all codes. Any thoughts? I pulled the exhaust valve and it seems to be fine. Thanks.

P13C7-
00
PENDING
The exhaust flap has an electrical fault or an open circuit.
P26DB-
00
PENDING
Control unit "Sound generator for exhaust system" has an electrical fault or open
circuit
 

·
Super Moderator
Joined
·
786 Posts
The exhaust flap mechanism could be electrically marginal and therefore threw an intermittent code. The flap is of course in a very high wear environment. If this continues you may want to replace. Note elsewhere discussion of same and that the similar Audi mechanism not only fits but is significantly less expensive.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #6 ·
Thanks, Huey. I saw that on the other post about the Audi part number. Long story but Mercedes dealer replaced that about 2 yrs ago, so it is fairly new and not much rain here in Las Vegas. In looking at it, the spring is in tact and the motor does move the valve. So far, it has just been a pending code, but I'm not sure how to get rid of it. I've got a track day coming up and don't want it to interfere with that.
 

·
Registered
Joined
·
271 Posts
I swapped out my August 2016 battery a month or so ago after enough Covid induced sitting times ran the battery flat too many times. It's important to remember to connect the battery tender!!!

The top cover slides forward, up, and off. It's a tight space to pull the OEM battery out of but the built in handles help. I installed the new non MB battery with no ill side affects and without a trip to the dealer.

Just to clarify, are you talking about the AUX batt? In our MB's, if we use the batt tender on the main battery, it does not also charge the AUX as part of the system? I ask because my main battery is pretty new from factory on warranty a year or so ago, but I just started getting the message my AUX batt has a malfunction.
 

·
Super Moderator
Joined
·
2,025 Posts
Yes, my description was for the main battery.

The aux battery has been a point of confusion regarding what it does and how it charges. One electrical drawing I have seen for it implies that a battery tender attached to the main battery should charge it. But another drawing implies the aux battery charges when rolling off the throttle and acts like a charge hold, mimicking a hybrid vehicle. In that case the tender won't charge it.

In the second case, when you have rolled off the throttle enough times such that the aux battery has enough stored charge to restart the motor then eco stop mode operates (when a number of other criteria are met). This fits my observations of how the car works and I'm inclined to believe this model.

I am not sure how the system evaluates the condition of the battery unless it is refusing to accept any charge.
 

·
Super Moderator
Joined
·
947 Posts
I think Wayne is correct in saying it is his second case that the AUX battery gets charged. The center display above the steering wheel has a screen showing current MPG and a coasting charge, which would mimic a hybrid vehicle.
 
  • Like
Reactions: Wayne

·
Super Moderator
Joined
·
2,025 Posts
I've got the 45 without that display, and many others, regarding any kind of efficiency!!!

Hmmmm ... Just noticed that's 2,000 posts. I guess talking efficiency is OK!!!
 

·
Super Moderator
Joined
·
947 Posts
Here are pictures of the display, one showing current mpg, and one showing Charge as I was coasting. This was on the 2016 GLA250 and on the 2019 GLA250.
Speedometer Vehicle Trip computer Odometer White
Speedometer Odometer Trip computer Car Tachometer
 
  • Like
Reactions: Wayne

·
Registered
Joined
·
271 Posts
Wow, like Wayne I don't have this either with the AMG, too bad, this display would be nice to have. In any case I agree with Wayne since I just topped up with my tender early in fall, this likely does not also charge the AUX.
 

·
Registered
Joined
·
29 Posts
So, after putting in a regular lead acid battery, I cleared a bunch of codes due to low battery voltage from the original battery fail. I keep getting these 2 codes after clearing all codes. Any thoughts? I pulled the exhaust valve and it seems to be fine. Thanks.

P13C7-
00
PENDING
The exhaust flap has an electrical fault or an open circuit.
P26DB-
00
PENDING
Control unit "Sound generator for exhaust system" has an electrical fault or open
circuit
so, i've had a bit of experience w/CELs coming from a main battery that was either low or didn't have enough CCA and so would throw a CEL. reason i'm saying this is because i'm running a small, lightweight battery in mine and i live in nebraska where it gets cold af this time of year. of course, the battery i'm using is borderline (CCA wise) in this type of weather lol:

Blue Motor vehicle Hood Vehicle Automotive exterior


so tl;dr: i often get a pending CEL when mine doesn't when to crank it over in the middle of freezing ass weather. usually it's related to the drivetrain / 4matic system. when i scan it, it shows as pending and will clear itself in a few days. hence, i'm not surprised you have a couple pending codes.
 
1 - 13 of 13 Posts
Top