Mercedes-Benz GLA Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, I recently bought a GLA 2019 and I see the support for Android Auto and Apple Car Play in the car system. Problem is that, when I plug in my phone (Galaxy S10) or my wife's phone (iPhone 7), I cannot get it to work with the car. Nothing happens. I allow all data to be transfered, I accept everything, but still, nothing shows up in the car screen.

I tried multiple different cables. Reseting the phones, reseting the car system, I tried with different phones, nothing helps. I am using the correct USB port, and still I cannot seem to connect the car to Android Auto or Car Play.

Anything I am missing here?
 

·
Registered
Joined
·
1 Posts
Did you find an answer to your issue? I've gone through the same and I've tried everything as well and still can't get it to connect. On top of that when talking over the phone (bluetooth) the call drops and it goes back to the phone, then it reconnects and it's a total mess.
 

·
Registered
Joined
·
51 Posts
This infotainment system is bad. I had my android hooked up and it displayed on the screen with google maps, etc. I hooked up my wife's apple and it worked fine, too, displaying on the screen. I tried to reconnect my android back to the screen and could not get it to show. Now, my wife's apple does not show on the screen either. Sometimes our phones will bluetooth connect for music, but not always. Crazy.
 

·
Super Moderator
Joined
·
2,025 Posts
We picked up one of the first 2017 models at the factory (August 2016). The trainers that presented the car for us insisted Carplay and AA were not available in the GLA. I pulled out my car history book with my order sheet showing the option. They were surprised. It took three phones before they got one to connect. Later that day at the hotel it took me several tries to get my phone to connect (AA). We used it a few times but found that AA (not MB) was unstable. And recovery (Waze) was tedious and potentially dangerous when driving requiring a full phone reset to unhang the phone. So we gave up.

Recently I rebuilt my 2010 Porsche 997.2 amp and added a board and external box to incorporate Carplay / AA into that car. The additions to Maps allow it to work really well, especially when out of network range, which happens a lot out here in the Western USA.

Note: My primary (only) use is navigation. Recently Waze (direct at phone rather than through the car) seems to be hanging up on long trips. Friends have noticed this as well. I suspect Google is playing games pushing people toward their upgraded Maps app that includes user feedback for traffic notifications. But that's just a suspicion.
 
1 - 7 of 7 Posts
Top