Mercedes-Benz GLA Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone. So 5 days ago I’ve added a ptp turbo blanket and a lava heat wrap for my down pipe(also from ptp.) After install (took a couple of days) I drove it the first time and noticed coolant leaking under my car. Found the issue and it was the coolant hose. It broke and I immediately got the new hose from dealership and fixed it promptly. (Back story) I’ve had the car for 1 n a half years and bought it with 35k miles. It’s now at 60k since it’s my daily. I took it to a local mechanic shop that is highly recommended by a lot of people in my area (Dallas Texas). Anyways I took it to a shop called “Motek Eurowerkz” They did my oil change, transmission fluid, differential fluid, and my coolant flush. Point of this story is, after they completed all of this. I was waiting in the main customer front room for 1 hr after the time it was suppose to be done. The front desk lady told me they had a problem with my car over heating and they needed to fix it and test drive it again to make sure it was okay. ( They “test drove it” 2 times) I have the mercedes’ me app for my 18’ gla and the miles went up 50+. Which leads me to think someone was driving it without me knowing… I’ll add a picture of my brand new cleaned floor mats that someone left super unprofessional and dirty. This was yesterday and today i went for some spiritual drives and my temps were way higher than expected and car felt super sluggish. For example, I was at a light and floored it when it turned green and during 2nd gear all power just stopped… I have a custom exhaust, armytrix downpipe and a weistch stage 2 tune. After these upgrades down the road was also added a weistech asv BOV (do i need to be retuned???? after this bov) I know this post is literally all over the place, but if anyone has any input, not necessarily on this shop, but ways to make sure my car is running the right way, please reach out. Thank you!
 

·
Registered
Joined
·
69 Posts
So, if they did not do any additional mx than what you listed, maybe there is air in the cooling system and it needs to be rebled? I'm not sure how that would be related to power problems, unless they returned your car back to stock.
 
1 - 4 of 4 Posts
Top