Mercedes-Benz GLA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Lately my GLA has been running hot. I even put more radiator fluid in and it's still running higher than halfway on the temperature gauge. Is this normal? This the temperature gauge while sitting at a drive thru.

See pic



Sent from my iPad using Tapatalk
 

·
Super Moderator
Joined
·
1,339 Posts
Welcome.

That looks normal. At least it's the same as our 45. This topic has come up before and the feedback had indicated equivalent readings.

Members here span the globe. And MB specifications can vary from country to country. When you get a chance visit the Control Panel to enter your region. This may help people answer your questions in the future.

Please, when you get a chance, post some pictures of your car and let us know your impressions.
 

·
Super Moderator
Joined
·
1,387 Posts
That's normal for my 250.
 

·
Registered
Joined
·
174 Posts
x10 normal range, certainly not hot. If you had the AMG, mine is in same range and is about 199* steady-eddie every single drive, AMG having a readout to actually tell you what your temp is.
 

·
Super Moderator
Joined
·
1,339 Posts
MB did a knock out job on their cooling system. Full temp is reached quickly and then accurately maintained over all driving conditions ... cool or hot ambient, simple commute, stuck in traffic, high altitude spirited mountain pass enjoyment, air conditioner full blast. Doesn't matter. I wish my Porsche was half as good!!!
 
1 - 8 of 8 Posts
Top