Loud clicking/ticking noise after shutting off the car - Mercedes GLA Forum
 
LinkBack Thread Tools
post #1 of 9 Old 09-09-2019, 09:01 PM Thread Starter
Junior Member
 
Join Date: Jan 2018
Location: New England, USA
Car Year & Model: 2018 GLA45
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Loud clicking/ticking noise after shutting off the car

Hi all, first time posting on this forum. I'm a 2018 GLA45 owner.

I noticed a loud clicking/ticking noise after turning off the car after about 15 min of driving. Prior to turning off the car, I did notice all the temperature gages seemed normal. The noise last for about 2-3min then it stopped. An immediate engine restart and shutoff resulted in the same clicking/ticking noise. I tried again (restart/shutoff) several hours later so the engine is cold and did not hear the clicking/ticking noise.

Couldn't find anything on this forum, but came across a thread ("Weird clicking noise once I shut the engine off") on the xbimmers forum describing a similar issue and identifying the source to a broken water coolant pump for the turbo.

Has anybody encounter this issue for GLA? I have a link to a video, but cannot post due to first-time poster.
jlinbitt is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 09-09-2019, 09:10 PM
Super Moderator
 
turbolink's Avatar
 
Join Date: Jun 2015
Location: Oahu, Hawaii
Car Year & Model: 2016 GLA250
Posts: 1,348
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 192 Post(s)
Welcome to the GLAowners forum. This has come up before and consensus was it was cat converters under the chassis cooling down. A similar question came up on a soft motor noise from the engine compartment long after shutdown, which pointed to a pump circulating fluid to cool the turbo, IIRC. Both are normal for our GLAs.

We’re an international group with a variety of GLA derivatives. As a reference to others in future posts, it helps to add location, GLA model and year to your member profile, which then displays under your name. You can do that from the User CP link on the upper right of most browsers.

2016 GLA250 FWD
Cirrus White, Brown Leather Upholstery, Burl Walnut Trim
Interior, Premium, Driver Assistance, Sport Packages
Rearview Camera, Power Passenger Seat With Memory
Bi-Xenon Headlights, LED Taillights
turbolink is online now  
post #3 of 9 Old 09-09-2019, 09:25 PM Thread Starter
Junior Member
 
Join Date: Jan 2018
Location: New England, USA
Car Year & Model: 2018 GLA45
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
@turbolink, thanks for the comment! Could I DM you a link to the video to confirm it is indeed cat converters cooling down. This is my first time hearing it from my car after ~1.5yrs of daily driving.
jlinbitt is offline  
 
post #4 of 9 Old 09-10-2019, 01:10 AM
Super Moderator
 
turbolink's Avatar
 
Join Date: Jun 2015
Location: Oahu, Hawaii
Car Year & Model: 2016 GLA250
Posts: 1,348
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 192 Post(s)
Video posted on behalf of jlinbitt. Can anyone identify the sound for our new member?

https://youtu.be/vJHfMlAfuaE

2016 GLA250 FWD
Cirrus White, Brown Leather Upholstery, Burl Walnut Trim
Interior, Premium, Driver Assistance, Sport Packages
Rearview Camera, Power Passenger Seat With Memory
Bi-Xenon Headlights, LED Taillights
turbolink is online now  
post #5 of 9 Old 09-12-2019, 08:58 PM Thread Starter
Junior Member
 
Join Date: Jan 2018
Location: New England, USA
Car Year & Model: 2018 GLA45
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
[Update]: Took it to the dealer. Confirmed that transmission cooler pump was failing and needed replacement. Once replaced, the ticking noise stopped.
jlinbitt is offline  
post #6 of 9 Old 09-12-2019, 09:35 PM
Super Moderator
 
Wayne's Avatar
 
Join Date: Mar 2016
Location: Northern California, Bay Area
Posts: 1,286
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 314 Post(s)
Thanks for reporting back. Covered under warranty? Common problem?
Wayne is online now  
post #7 of 9 Old 09-12-2019, 10:16 PM Thread Starter
Junior Member
 
Join Date: Jan 2018
Location: New England, USA
Car Year & Model: 2018 GLA45
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Covered under warranty. I don't know if it is a common issue for GLA45, but there is a thread on "water pump failure" on this forum mostly identified by overheating warning lights if I recall.

I was able to find another video showing a similar clicking noise after engine shutoff and ended up being a failing coolant pump on the xbimmers forum; thread title is "Weird clicking noise once I shut the engine off". I'm still new to this forum and cannot post links.
jlinbitt is offline  
post #8 of 9 Old 09-12-2019, 10:47 PM
Super Moderator
 
Wayne's Avatar
 
Join Date: Mar 2016
Location: Northern California, Bay Area
Posts: 1,286
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 314 Post(s)
Thanks again.. Glad you're back on the road.
Wayne is online now  
post #9 of 9 Old 09-13-2019, 11:03 AM
Member
 
RichZilla's Avatar
 
Join Date: May 2019
Location: Minnesota, USA
Car Year & Model: 2018 GLA45
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Yes, thanks for sharing! Now hopefully I can remember this if my car ever starts making that sound...

To hesitate is a waste of time.
RichZilla is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome